S4 Training Modules

GeoDa: Spatial Regression

Spatial Regression with GeoDa

This lab includes discussion of two types of models of spatial dependence
1) Spatial lag
2) Spatial error
It then shows how to estimate simple spatial regression models in GeoDa
1) Classical OLS regression with diagnostics
2) Spatial lag model vs. Spatial error model
Data and Shapefiles:
We will use a US 2000 Census data for Manhattan in New York City. The zipped data
file is on the S4 Training page and can be downloaded from
http://www.s4.brown.edu/S4/about.htm click on S4 tutorials; scroll down to GeoDa 3.
The shapefile newyork.shp is the map of Manhattan in New York City with Census
2000 data from summary file 3. These are socioeconomic attributes for 297 Census
tracts. It includes the following variables:
Vraiable name Label
POLYID
STATE
COUNTY
TRACT
sctrct00
hvalue
t0_pop
pctnhw
pctnhb
pcthsp
pctasn
t0p_own
t0p_coll
t0p_prf
t0p_uemp
t0p_for
t0p_rec
t0_minc
t0p_poor

Polygon ID
State FIPS
County FIPS
Census Tract ID
FIPSID
Median housing value
Total population
Percent non-Hispanic white persons
Percent non-Hispanic black persons
Percent Hispanic persons
Percent Asian persons
Percent homeowners
Percent college educated
Percent of people employed in professional/managerial occupations
Percent of people unemployed
Percent foreign born persons
Percent recent immigrants
Median household income
Percent total population below poverty

1
Spatial Structures in the Social Sciences

S4 Training Modules

GeoDa: Spatial Regression

1. Standard linear regression - Ordinary Least Squares (OLS)
The general purpose of linear regression analysis is to find a (linear) relationship
between a dependent variable and a set of explanatory variables:
y = Xβ +ε

The method of ordinary least squares (OLS) estimation is referred to as a Best Linear
Unbiased Estimator (BLUE). The OLS estimates β by minimizing the sum of squared
prediction errors, hence, least squares. In order to obtain the BLUE property and make
statistical inferences about the population regression coefficients from the estimated b,
certain assumptions about the random error of the regression equation need to be made.
These include:
a) the random errors have a mean of zero (there is no systematic misspecification or bias
in the population regression equation);
b) the random errors have a constant variance (homoskedasticity) and are uncorrelated;
c) the random errors have a normal distribution.
2. Spatial dependence
These assumptions may not be always satisfied in practice. When a value observed in
one location depends on the values observed at neighboring locations, there is a spatial
dependence. And spatial data may show spatial dependence in the variables and error
terms.
Why should spatial dependence occur? There are two reasons commonly given. First,
data collection of observations associated with spatial units may reflect measurement
error. This happens when the boundaries for which information is collected do not
accurately reflect the nature of the underlying process generating the sample data.
A second reason for spatial dependence is that the spatial dimension of a social or
economic characteristic may be an important aspect of the phenomenon. For example,
based on the premise that location and distance are important forces at work, regional
science theory relies on notions of spatial interaction and diffusion effects, hierarchies of
place and spatial spillovers.
There are two primary types of spatial dependence:
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a. Spatial error -the error terms across different spatial units are correlated

Xi

Xj

yi yj
εi

εj

With spatial error in OLS regression, the assumption of uncorrelated error terms is
violated. As a result, the estimates are inefficient. Spatial error is indicative of omitted
(spatially correlated) covariates that if left unattended would affect inference.
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b. Spatial lag- the dependent variable y in place i is affected by the independent
variables in both place i and j.

Xi

Xj

yi yj
εi

εj

With spatial lag in OLS regression, the assumption of uncorrelated error terms is
violated; in addition, the assumption of independent observations is also violated. As a
result, the estimates are biased and inefficient. Spatial lag is suggestive of a possible
diffusion process – events in one place predict an increased likelihood of similar events
in neighboring places.
GeoDa provides a range of diagnostics to detect spatial dependence. It also provides
unbiased regression estimates using a Maximum Likelihood approach (ML Spatial Lag
or Spatial Error models).
3. Spatial regression in GeoDa
Start a project and create weights matrix
a. Start GeoDa by Click the Start > Programs > Instructional Tools >
GeoDa,
b. Go to File > Open Project .
c. Browse through the folder to find and select the shape file, newyork.shp.
d. Select POLYID as the “Key Variable” (by scrolling and clicking on variable name). The
Key Variable must have a unique value for each observation (i.e., in this case Census
tract). The unique value is used to implement the link between maps and statistical
graphs.
e. Click OK. Your screen should now look something like …
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f. Create a weights matrix. Go to Tools > Weights > Create to open the
Creating Weights dialogue box.

In the Creating weights dialogue box:
Select newyork.shp as the input, type “rook” in the Save output as (the default
extension is .gal), Select POLYID as the ID variable for the weights file.
Select Rook Contiguity, click Create, then Done.
3.1. Classical OLS regression with diagnostics.
Now, we are ready to perform an OLS regression and evaluate the spatial dependence in
this regression.
a. On the menu bar, choose Regress. A dialogue box will appear:

5
Spatial Structures in the Social Sciences

S4 Training Modules

GeoDa: Spatial Regression

This box inquires the information to be included in the output results. Check Moran’s
I z-value as shown, and click OK.
b. A variable selection box will appear:

In this example, we will predict neighborhood homeownership with several indicators,
including % non-Hispanic white, % non-Hispanic black, % college+ educated,
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unemployment rate, % foreign born, median household income, and % person below
poverty.
Browse to locate the weights matrix file you just created and check the Weight Files
box.
c. Check Classic- this will run classical OLS regression with spatial dependence
diagnostics, click Run. When done, click OK.
d. A new window of regression output will appear, and it has several sections.
1) The first section is the summary output of OLS regression:

It first shows general information of the run, including the mean and standard deviation
of the dependent variable, the model coefficient of determination, F-test probability,
and Log likelihood. Then, the coefficients, standard errors, and significance are shown.
We can see that among the seven indicators, % non-Hispanic white, % non-Hispanic
black, % college+ educated, and median household income are positively related to
homeownership; while poverty rate is negatively related to homeownership; and
unemployment rate and % foreign born have insignificant effects.
2) The next section deals with regression diagnostics:
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GeoDa tests multicollinearity of the model- one should be alarmed when
MULTICOLLINEARITY CONDITION NUMBER is greater than 20. The Jarque-Bera test
is used to examine the normality of the distribution of the errors. This test is a test of the
combined effects of both skewness and Kurtosis. The low probability of the test score
indicates non-normal distribution of the error term. Since the following tests of variance
and spatial dependence are conditioned upon normal distribution, in real research, one
should be very cautious to interpret the test results. Here, we simply give the illustration
of how to interpret the diagnostics when non-normality is not encountered.
3) DIAGNOSTICS FOR HETEROSKEDASTICITY- a test of the variance of the error
term as the BLUE requires constant error variance.

The low probabilities of the three tests point to existence of heteroskedasticity. This is
not necessarily a surprise because the error variance could well be affected by the spatial
dependence in the data.
4) DIAGNOSTICS FOR SPATIAL DEPENDENCE

There are six tests performed to assess the spatial dependence of the model. First,
Moran’s I score of 0.196 is highly significant, indicating strong spatial autocorrelation of
the residuals. In addition, the function reports the estimates of tests chosen among five
statistics for testing for spatial dependence in linear models. The statistics are the
simple LM test for a missing spatially lagged dependent variable (Lagrange Multiplier
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(lag)), the simple LM test for error dependence (Lagrange Multiplier (error)), variants of
these robust to the presence of the other (Robust LM (lag) and Robust LM (error)which tests for error dependence in the possible presence of a missing lagged dependent
variable, Robust LM (lag) is the other way round), and a portmanteau test (SARMA, in
fact Lagrange Multiplier (error) + Robust LM (lag)).
We can see both simple tests of the lag and error are significant, indicating presence of
spatial dependence. The robust tests help us understand what type of spatial
dependence may be at work. The robust measure for error is still significant, but the
robust lag test becomes insignificant, which means that when lagged dependent variable
is present the error dependence disappears.
3.2. Spatial lag model vs. spatial error model
After identifying the presence of spatial dependence, we will use GeoDa to re-estimate
the model with maximum likelihood approach while controlling for the spatial
dependence.
a. On the menu bar, choose Regress. Check Moran’s I z-value in the output box,
and click OK.
b. In the variable selection box, set dependent and independent variables as before.
Check Weight Files, and browse to locate the weights matrix file.
c. Check Spatial Lag in the Models selection, and click Run.
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d. Check Spatial Error and click Run. Then click OK.
e. Two new windows of regression output will appear, and they present results for both
spatial lag and spatial error models.
1) First, we see the results from spatial lag model. Again, it consists of multiple sections
and begins with general information and regression coefficients with significance tests.

Notice, besides the information that appeared in previous OLS regression output, we
have a designated spatial weight file: rook.GAL. And the spatial lag term of
homeownership W_T0P_OWN appeared as an additional indicator. (Its coefficient
parameter (Rho) reflects the spatial dependence inherent in our sample data, measuring
the average influence on observations by their neighboring observations.) It has a
positive effect and it is highly significant. As a result, the general model fit improved, as
indicated in higher values of R-squared and Log likelihood. The effects of other
independent variables remain virtually the same.
2) The following sections show tests of Heteroskedasticity and Spatial dependence.
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We can see that the low probability in the Breusch-Pagan test suggests that there is still
Heteroskedasticity in the model after introducing the spatial lag term. And in the
Likelihood Ratio Test of Spatial Lag Dependence, the result is still significant. Therefore,
we conclude that although the introduction of spatial lag term improved the model fit, it
didn’t make the spatial effects go away.
3) Now let’s review results for the Spatial Error model.

In comparison with the Spatial Lag model output, we also have a designated spatial
weight file: rook.GAL. And a coefficient on the spatially correlated errors (LAMBDA) is
added as an additional indicator. It has a positive effect and it is highly significant. As a
result, the general model fit improved, as indicated in higher values of R-squared and
Log likelihood. Like the lag model, the effects of other independent variables remain
virtually the same.
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4) Diagnostics of Heteroskedasticity and spatial independence

Similar to the lag model, the Heteroskedasticity test remains significant. Also, the
Likelihood Ratio Test of Spatial Error Dependence has a significant result. Therefore, we
conclude that although allowing the error terms to be spatially correlated improved the
model fit, it didn’t make the spatial effects go away.
5) What should we conclude?
Comparing the spatial lag and spatial error models, we can see both alternative models
yield improvement to the original OLS model. Therefore, we should conclude that
controlling spatial dependence will improve our model performance. Now the question
is which of the two models is better? To some extent, this is an open question. The
general advice is first to look for a theoretical basis to inform your choice. If there are
strong substantive grounds for one model instead of the other, you should adopt it.
When it is not so clear theoretically, you can compare the model performance
parameters: the R-squared and Log likelihood. In our case, the spatial error model has
greater R-squared and Log likelihood values. That provides a statistical basis to adopt
this solution.
4. Another example
Now, do another exercise with % person below poverty as dependent variable, and %
non-Hispanic white, % non-Hispanic black, % college+ educated, unemployment rate, %
foreign born, and median household income as independent variables. Run OLS
regression, interpret the regression and spatial dependence diagnostics; if spatial
dependence exists, try to re-estimate the models with Spatial lag model and Spatial
Error model, then compare the output and make your choice.
In this session, we learned to use GeoDa to examine and control spatial dependence in
the regression models. By now, you should know the general strategy applied in GeoDa
to deal with the spatial dependence issue. You should be able to understand the various
diagnostics and regression tests, and able to interpret the results and make decisions
accordingly.
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